There shouldn’t be any need to define this function.
define_register will create it automatically
Can we move this to
define_filtered_register. That way, it will automatically remove the item from the register when the plugin is disabled. There is a little documentation at the top of this file about how it all works.
I think we should make the name parameter required. I can’t think of any reason when you would want to call this function without a name.