Build(deps): Bump rubocop from 0.83.0 to 0.84.0 (#9849)

Build(deps): Bump rubocop from 0.83.0 to 0.84.0 (#9849)

Bumps rubocop from 0.83.0 to 0.84.0.

Signed-off-by: dependabot-preview[bot] support@dependabot.com

Co-authored-by: dependabot-preview[bot] <27856297+dependabot-preview[bot]@users.noreply.github.com>

diff --git a/Gemfile.lock b/Gemfile.lock
index 6d65777..db4b88d 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -343,13 +343,16 @@ GEM
       json-schema (~> 2.2)
       railties (>= 3.1, < 7.0)
     rtlit (0.0.5)
-    rubocop (0.83.0)
+    rubocop (0.84.0)
       parallel (~> 1.10)
       parser (>= 2.7.0.1)
       rainbow (>= 2.2.2, < 4.0)
       rexml
+      rubocop-ast (>= 0.0.3)
       ruby-progressbar (~> 1.7)
       unicode-display_width (>= 1.4.0, < 2.0)
+    rubocop-ast (0.0.3)
+      parser (>= 2.7.0.1)
     rubocop-discourse (2.1.2)
       rubocop (>= 0.69.0)
       rubocop-rspec (>= 1.39.0)

GitHub sha: 11304ba2

This commit appears in #9849 which was approved by eviltrout. It was merged by eviltrout.