Build(deps): Bump rubocop-rspec from 1.41.0 to 1.42.0 (#10207)

Build(deps): Bump rubocop-rspec from 1.41.0 to 1.42.0 (#10207)

Bumps rubocop-rspec from 1.41.0 to 1.42.0.

Signed-off-by: dependabot-preview[bot] support@dependabot.com

Co-authored-by: dependabot-preview[bot] <27856297+dependabot-preview[bot]@users.noreply.github.com>

diff --git a/Gemfile.lock b/Gemfile.lock
index 56737af..30975b6 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -362,8 +362,8 @@ GEM
     rubocop-discourse (2.2.0)
       rubocop (>= 0.69.0)
       rubocop-rspec (>= 1.39.0)
-    rubocop-rspec (1.41.0)
-      rubocop (>= 0.68.1)
+    rubocop-rspec (1.42.0)
+      rubocop (>= 0.87.0)
     ruby-prof (1.4.1)
     ruby-progressbar (1.10.1)
     ruby-readability (0.7.0)

GitHub sha: c5da813f

This commit appears in #10207 which was merged by eviltrout.