Bump gem versions, but nuke rubocop anyway

Bump gem versions, but nuke rubocop anyway

It’s complaining about cops it doesn’t know about, I don’t care.

diff --git a/Gemfile b/Gemfile
index 79b6fe8..9544b55 100644
--- a/Gemfile
+++ b/Gemfile
@@ -23,6 +23,8 @@ group :development do
   gem 'redcarpet'
   gem 'rspec'
   gem 'rubocop'
+  gem 'rubocop-discourse'
+  gem 'rubocop-rspec'
   gem 'simplecov'
   gem 'yard'
 end
diff --git a/Gemfile.lock b/Gemfile.lock
index 0330e0a..469a048 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -35,7 +35,7 @@ GEM
     guard-rubocop (1.3.0)
       guard (~> 2.0)
       rubocop (~> 0.20)
-    jaro_winkler (1.5.2)
+    jaro_winkler (1.5.4)
     json (2.1.0)
     listen (3.1.5)
       rb-fsevent (~> 0.9, >= 0.9.4)
@@ -51,10 +51,9 @@ GEM
       nenv (~> 0.1)
       shellany (~> 0.0)
     optimist (3.0.0)
-    parallel (1.13.0)
-    parser (2.6.0.0)
+    parallel (1.19.1)
+    parser (2.7.1.1)
       ast (~> 2.4.0)
-    powerpack (0.1.2)
     prometheus_exporter (0.4.4)
     pry (0.12.2)
       coderay (~> 1.1.0)
@@ -72,6 +71,7 @@ GEM
       msgpack (>= 0.4.3)
       optimist (>= 3.0.0)
     redcarpet (3.4.0)
+    rexml (3.2.4)
     rspec (3.8.0)
       rspec-core (~> 3.8.0)
       rspec-expectations (~> 3.8.0)
@@ -85,15 +85,19 @@ GEM
       diff-lcs (>= 1.2.0, < 2.0)
       rspec-support (~> 3.8.0)
     rspec-support (3.8.0)
-    rubocop (0.64.0)
+    rubocop (0.81.0)
       jaro_winkler (~> 1.5.1)
       parallel (~> 1.10)
-      parser (>= 2.5, != 2.5.1.1)
-      powerpack (~> 0.1)
+      parser (>= 2.7.0.1)
       rainbow (>= 2.2.2, < 4.0)
+      rexml
       ruby-progressbar (~> 1.7)
-      unicode-display_width (~> 1.4.0)
-    ruby-progressbar (1.10.0)
+      unicode-display_width (>= 1.4.0, < 2.0)
+    rubocop-discourse (2.0.1)
+      rubocop (>= 0.69.0)
+    rubocop-rspec (1.38.1)
+      rubocop (>= 0.68.1)
+    ruby-progressbar (1.10.1)
     ruby_dep (1.5.0)
     shellany (0.0.1)
     sigdump (0.2.4)
@@ -104,7 +108,7 @@ GEM
     simplecov-html (0.10.2)
     stackprof (0.2.12)
     thor (0.20.3)
-    unicode-display_width (1.4.1)
+    unicode-display_width (1.7.0)
     yard (0.9.20)
 
 PLATFORMS
@@ -126,6 +130,8 @@ DEPENDENCIES
   redcarpet
   rspec
   rubocop
+  rubocop-discourse
+  rubocop-rspec
   sigdump
   simplecov
   stackprof
@@ -135,4 +141,4 @@ RUBY VERSION
    ruby 2.3.3p222
 
 BUNDLED WITH
-   1.17.2
+   1.17.3
diff --git a/Rakefile b/Rakefile
index d700a09..9cee614 100644
--- a/Rakefile
+++ b/Rakefile
@@ -1,7 +1,6 @@
 exec(*(["bundle", "exec", $PROGRAM_NAME] + ARGV)) if ENV['BUNDLE_GEMFILE'].nil?
 
 task default: :test
-task default: :rubocop
 task default: :doc_stats
 
 begin
@@ -29,10 +28,6 @@ end
 
 require 'yard'
 
-task :rubocop do
-  sh "rubocop"
-end
-
 task :doc_stats do
   sh "yard stats --list-undoc"
 end

GitHub sha: 73326919