DEV: Bump eslint-config-discourse again (PR #14873)

Now all the plugins are updated it is safe to bump to 1.1.9

GitHub