DEV: Bump Hashie and Faraday (#9583)

DEV: Bump Hashie and Faraday (#9583)

These were previously pinned due to a dependency in the zendesk plugin. That has now been resolved.

diff --git a/Gemfile b/Gemfile
index 925f81b..2b1fb36 100644
--- a/Gemfile
+++ b/Gemfile
@@ -257,10 +257,3 @@ end
 gem 'webpush', require: false
 gem 'colored2', require: false
 gem 'maxminddb'
-
-# These are not direct dependencies, but we need to restrict
-# versions for compatibility with https://github.com/discourse/discourse-zendesk-plugin
-# These restrictions can be removed once the zendesk_api gem is updated
-# for newer versions of hashie and faraday
-gem 'hashie', '< 4.0.0', require: false # https://github.com/zendesk/zendesk_api_client_rb/pull/422
-gem 'faraday', '< 1.0.0', require: false # https://github.com/zendesk/zendesk_api_client_rb/pull/421
diff --git a/Gemfile.lock b/Gemfile.lock
index 7cb6c2e..5fc2845 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -126,7 +126,7 @@ GEM
     exifr (1.3.6)
     fabrication (2.21.1)
     fakeweb (1.3.0)
-    faraday (0.17.3)
+    faraday (1.0.1)
       multipart-post (>= 1.2, < 3)
     fast_blank (1.0.0)
     fast_xor (1.1.3)
@@ -142,7 +142,7 @@ GEM
       activesupport (>= 4.2.0)
     guess_html_encoding (0.0.11)
     hashdiff (1.0.1)
-    hashie (3.6.0)
+    hashie (4.1.0)
     highline (1.7.10)
     hkdf (0.3.0)
     htmlentities (4.3.4)
@@ -463,14 +463,12 @@ DEPENDENCIES
   execjs
   fabrication
   fakeweb
-  faraday (< 1.0.0)
   fast_blank
   fast_xor
   fast_xs
   fastimage
   flamegraph
   gc_tracer
-  hashie (< 4.0.0)
   highline (~> 1.7.0)
   htmlentities
   http_accept_language

GitHub sha: 6a9a7b56

This commit appears in #9583 which was merged by davidtaylorhq.