DEV: Bump rotp gem to latest version (PR #10472)

The rotp gem is currently pinned to version 5.1.0 and this will bump it up to version 6.0.1.

Follow up to: 85d4370f791a2e6e17a50cd9ab5de44cd1fcc0d2

because this issue we were waiting on is now closed:

https://github.com/mdp/rotp/issues/98

Because version 6 is now encoding the params I needed to update the tests as well.

GitHub

I thought my git commit message would auto link to: DEV: pin the rotp gem · discourse/discourse@85d4370 · GitHub