DEV: Bump rubocop-ast from 0.2.0 to 0.3.0 (#10353)

DEV: Bump rubocop-ast from 0.2.0 to 0.3.0 (#10353)

Bumps rubocop-ast from 0.2.0 to 0.3.0.

Signed-off-by: dependabot-preview[bot] support@dependabot.com

Co-authored-by: dependabot-preview[bot] <27856297+dependabot-preview[bot]@users.noreply.github.com>

diff --git a/Gemfile.lock b/Gemfile.lock
index 2a75d93..c26014c 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -357,8 +357,8 @@ GEM
       rubocop-ast (>= 0.1.0, < 1.0)
       ruby-progressbar (~> 1.7)
       unicode-display_width (>= 1.4.0, < 2.0)
-    rubocop-ast (0.2.0)
-      parser (>= 2.7.0.1)
+    rubocop-ast (0.3.0)
+      parser (>= 2.7.1.4)
     rubocop-discourse (2.3.1)
       rubocop (>= 0.69.0)
       rubocop-rspec (>= 1.39.0)

GitHub sha: ea7e7900

This commit appears in #10353 which was merged by SamSaffron.