DEV: Bump rubocop from 0.84.0 to 0.85.0 (#9960)

DEV: Bump rubocop from 0.84.0 to 0.85.0 (#9960)

Bumps rubocop from 0.84.0 to 0.85.0.

Signed-off-by: dependabot-preview[bot] support@dependabot.com

Co-authored-by: dependabot-preview[bot] <27856297+dependabot-preview[bot]@users.noreply.github.com>

Change looks safe, everything is still passing lint

diff --git a/Gemfile.lock b/Gemfile.lock
index 6bf999c..2b1a406 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -311,6 +311,7 @@ GEM
     redis (4.1.4)
     redis-namespace (1.7.0)
       redis (>= 3.0.4)
+    regexp_parser (1.7.0)
     request_store (1.5.0)
       rack (>= 1.4)
     rexml (3.2.4)
@@ -350,10 +351,11 @@ GEM
       json-schema (~> 2.2)
       railties (>= 3.1, < 7.0)
     rtlit (0.0.5)
-    rubocop (0.84.0)
+    rubocop (0.85.0)
       parallel (~> 1.10)
       parser (>= 2.7.0.1)
       rainbow (>= 2.2.2, < 4.0)
+      regexp_parser (>= 1.7)
       rexml
       rubocop-ast (>= 0.0.3)
       ruby-progressbar (~> 1.7)

GitHub sha: 111e8dec

This commit appears in #9960 which was merged by SamSaffron.