DEV: Correct the ruby version check (PR #12551)

also fix discourse cannot work with ruby 3.0.0

GitHub

CLA assistant check
Thank you for your submission! We really appreciate it. Like many open source projects, we ask that you sign our Contributor License Agreement before we can accept your contribution.
You have signed the CLA already but the status is still pending? Let us recheck it.

The title of this pull request changed from “compare semver elegantly” to "compare semver elegantly & compatible with ruby 3.0.0

for totally compatible with ruby 3.0.0 we still need to fix issues such as this one.

but change the way we compare semver is always a net win.

  if Gem::Version.new(RUBY_VERSION) < Gem::Version.new("2.5.2")

The title of this pull request changed from “compare semver elegantly & compatible with ruby 3.0.0” to "DEV: Correct the ruby version check

Thank you! :smiley:

@CvX thanks for your review! I’ll try to run discourse on Ruby 3.0.0 later :slight_smile: