DEV: disallow travis running rails master on 2.4 and below

DEV: disallow travis running rails master on 2.4 and below

Also removes unsupported Ruby 2.2 from the matrix as it is EOL

diff --git a/.travis.yml b/.travis.yml
index d695033..644d57f 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,18 +1,25 @@
 language: ruby
-rvm:
-  - 2.2
-  - 2.3
-  - 2.4
-  - 2.5
-  - 2.6
-
-gemfile:
-  - gemfiles/rails_4.gemfile
-  - gemfiles/rails_5.gemfile
-  - gemfiles/rails_master.gemfile
-
 matrix:
   fast_finish: true
+  include:
+    - rvm: 2.3
+      gemfile:
+        - gemfiles/rails_4.gemfile
+        - gemfiles/rails_5.gemfile
+    - rvm: 2.4
+      gemfile:
+        - gemfiles/rails_4.gemfile
+        - gemfiles/rails_5.gemfile
+    - rvm: 2.5
+      gemfile:
+        - gemfiles/rails_4.gemfile
+        - gemfiles/rails_5.gemfile
+        - gemfiles/rails_master.gemfile
+    - rvm: 2.6
+      gemfile:
+        - gemfiles/rails_4.gemfile
+        - gemfiles/rails_5.gemfile
+        - gemfiles/rails_master.gemfile
 
 cache: bundler
 
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 2f4a61e..760f6be 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,7 @@
 ## 2.0.7 - 04-02-2019
 
  * Add support for Rails 6
+ * Remove support for Ruby 2.2 as it is EOL
 
 ## 2.0.6 - 23-01-2019
 
diff --git a/rails_multisite.gemspec b/rails_multisite.gemspec
index ad05fcd..1657a02 100644
--- a/rails_multisite.gemspec
+++ b/rails_multisite.gemspec
@@ -19,7 +19,7 @@ Gem::Specification.new do |gem|
   gem.require_paths = ["lib"]
   gem.version       = RailsMultisite::VERSION
 
-  gem.required_ruby_version = ">=2.2.0"
+  gem.required_ruby_version = ">=2.3.0"
 
   %w{activerecord railties}.each do |gem_name|
     gem.add_dependency gem_name, "> 4.2", "< 7"

GitHub sha: 4e1b1d45