DEV: Display FA 4.7 deprecation notice in all environments

DEV: Display FA 4.7 deprecation notice in all environments

FA 4.7 icon mapping will be removed soon.

diff --git a/app/assets/javascripts/discourse-common/lib/icon-library.js.es6 b/app/assets/javascripts/discourse-common/lib/icon-library.js.es6
index d5aecd7..9821368 100644
--- a/app/assets/javascripts/discourse-common/lib/icon-library.js.es6
+++ b/app/assets/javascripts/discourse-common/lib/icon-library.js.es6
@@ -579,13 +579,9 @@ function warnIfMissing(id) {
 }
 
 function warnIfDeprecated(oldId, newId) {
-  if (
-    typeof Discourse !== "undefined" &&
-    Discourse.Environment === "development" &&
-    !Ember.testing
-  ) {
-    deprecated(`Icon "${oldId}" is now "${newId}".`);
-  }
+  deprecated(
+    `Please replace all occurrences of "${oldId}"" with "${newId}". FontAwesome 4.7 icon names are now deprecated and will be removed in the next release.`
+  );
 }
 
 function handleIconId(icon) {

GitHub sha: 042f7184