DEV: Do not prompt to run `yarn` in dev env (PR #13167)

Since DEV: Run `yarn install` when running `bin/ember-cli` by eviltrout · Pull Request #13102 · discourse/discourse · GitHub, a separate yarn install is no longer needed (it’s run in bin/ember-cli.

GitHub