DEV: Drop unsupported-browser plugin (PR #10261)

Discourse 2.6 will not have support for older browsers (e.g. IE11)

GitHub

YEEEEESSSSSSS