DEV: Fix a deprecated `ember` import (#9903)

diff --git a/app/assets/javascripts/discourse-loader.js b/app/assets/javascripts/discourse-loader.js
index fc829ae..6e36f80 100644
--- a/app/assets/javascripts/discourse-loader.js
+++ b/app/assets/javascripts/discourse-loader.js
@@ -29,6 +29,7 @@ var define, requirejs;
         inject: Ember.inject.controller
       },
       "@ember/debug": {
+        isTesting: () => Ember.testing,
         warn: Ember.warn
       },
       "@ember/object": {
diff --git a/app/assets/javascripts/discourse/app/helpers/page-reloader.js b/app/assets/javascripts/discourse/app/helpers/page-reloader.js
index 6429be3..ad97159 100644
--- a/app/assets/javascripts/discourse/app/helpers/page-reloader.js
+++ b/app/assets/javascripts/discourse/app/helpers/page-reloader.js
@@ -1,9 +1,9 @@
 import EmberObject from "@ember/object";
-import Ember from "ember";
+import { isTesting } from "@ember/debug";
 
 export default EmberObject.create({
-  reload: function() {
-    if (!Ember.testing) {
+  reload() {
+    if (!isTesting()) {
       location.reload();
     }
   }

GitHub sha: 75f46ca6

1 Like

This commit appears in #9903 which was approved by eviltrout. It was merged by CvX.