DEV: Fix an `ActiveModel::Errors` deprecation (PR #13302)

The warning was:

DEPRECATION WARNING: Calling `<<` to an ActiveModel::Errors message array
in order to add an error is deprecated. Please call `ActiveModel::Errors#add` instead.
(called from block (3 levels) in activate! at discourse/plugins/poll/plugin.rb:519)

GitHub