DEV: Fix deprecation warning after updating to messabe_bus 4.0.0. (PR #15562)

MessageBus.reliable_pub_sub is deprecated, use MessageBus.backend_instance instead.

Follow-up to aee9fcd2571516ba3c852a1858bef2e4f605cc37

GitHub