DEV: Fix one more use of `jQuery` global (#14910)

DEV: Fix one more use of jQuery global (#14910)

diff --git a/plugins/poll/assets/javascripts/widgets/discourse-poll.js.es6 b/plugins/poll/assets/javascripts/widgets/discourse-poll.js.es6
index 6b476de..471f748 100644
--- a/plugins/poll/assets/javascripts/widgets/discourse-poll.js.es6
+++ b/plugins/poll/assets/javascripts/widgets/discourse-poll.js.es6
@@ -791,7 +791,7 @@ export default createWidget("discourse-poll", {
       (attrs.post.get("topic.archived") && !staffOnly) ||
       (this.isClosed() && !staffOnly);
 
-    const newAttrs = jQuery.extend({}, attrs, {
+    const newAttrs = Object.assign({}, attrs, {
       canCastVotes: this.canCastVotes(),
       hasVoted: this.hasVoted(),
       isAutomaticallyClosed: this.isAutomaticallyClosed(),

GitHub sha: 9c6ad955aafcc96148a22e5b0cd045e4179f0d19

This commit appears in #14910 which was approved by pmusaraj. It was merged by CvX.