DEV: Fix uploads controller flaky presigned put spec (PR #13985)

Was missing RateLimiter.clear_all!, leading to 403 errors.

GitHub

This solves the problem better DEV: Move rate limiter disable to after :each for tests by martin-brennan · Pull Request #13986 · discourse/discourse · GitHub