DEV: Fix usage of deprecated global

DEV: Fix usage of deprecated global

diff --git a/assets/javascripts/discourse/components/ad-component.js.es6 b/assets/javascripts/discourse/components/ad-component.js.es6
index 45b8c5f..40b9be2 100644
--- a/assets/javascripts/discourse/components/ad-component.js.es6
+++ b/assets/javascripts/discourse/components/ad-component.js.es6
@@ -40,7 +40,7 @@ export default Ember.Component.extend({
 
   @discourseComputed("currentUser.groups")
   showToGroups(groups) {
-    const currentUser = Discourse.User.current();
+    const currentUser = this.currentUser;
 
     if (
       !currentUser ||

GitHub sha: 4ded0bdb

1 Like