DEV: Fix warning about already initialized constants in `FileStore::BaseStore`

DEV: Fix warning about already initialized constants in FileStore::BaseStore

diff --git a/lib/discourse.rb b/lib/discourse.rb
index ea2a3cb..23e5e64 100644
--- a/lib/discourse.rb
+++ b/lib/discourse.rb
@@ -9,12 +9,6 @@ require_dependency 'auth/default_current_user_provider'
 require_dependency 'version'
 require 'digest/sha1'
 
-# Prevents errors with reloading dev with conditional includes
-if Rails.env.development?
-  require_dependency 'file_store/s3_store'
-  require_dependency 'file_store/local_store'
-end
-
 module Discourse
   DB_POST_MIGRATE_PATH ||= "db/post_migrate"
   REQUESTED_HOSTNAME ||= "REQUESTED_HOSTNAME"

GitHub sha: c1c09041

This commit appears in #13202 which was approved by CvX and tgxworld. It was merged by tgxworld.