DEV: low risk gem updates

DEV: low risk gem updates

This updates another batch of gems that are lowish risk

Most of the gem changes are here for Rails 6 / Ruby 2.6.3 support

Excon did some stuff around better cipher ordering

diff --git a/Gemfile.lock b/Gemfile.lock
index 97656f7..70bbd35 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -61,22 +61,22 @@ GEM
       aws-sdk-core (~> 3, >= 3.39.0)
       aws-sigv4 (~> 1.0)
     aws-sigv4 (1.0.3)
-    barber (0.12.0)
+    barber (0.12.2)
       ember-source (>= 1.0, < 3.1)
       execjs (>= 1.2, < 3)
-    better_errors (2.5.0)
+    better_errors (2.5.1)
       coderay (>= 1.0.0)
       erubi (>= 1.0.0)
       rack (>= 0.9.0)
     binding_of_caller (0.8.0)
       debug_inspector (>= 0.0.1)
-    bootsnap (1.3.2)
+    bootsnap (1.4.4)
       msgpack (~> 1.0)
     builder (3.2.3)
-    bullet (5.9.0)
+    bullet (6.0.0)
       activesupport (>= 3.0.0)
       uniform_notifier (~> 1.11)
-    byebug (10.0.2)
+    byebug (11.0.1)
     certified (1.0.0)
     chunky_png (1.3.11)
     claide (1.0.2)
@@ -94,7 +94,7 @@ GEM
     crack (0.4.3)
       safe_yaml (~> 1.0.0)
     crass (1.0.4)
-    danger (5.13.0)
+    danger (6.0.6)
       claide (~> 1.0)
       claide-plugins (>= 0.9.2)
       colored2 (~> 3.1)
@@ -102,7 +102,8 @@ GEM
       faraday (~> 0.9)
       faraday-http-cache (~> 1.0)
       git (~> 1.5)
-      kramdown (~> 1.5)
+      kramdown (~> 2.0)
+      kramdown-parser-gfm (~> 1.0)
       no_proxy_fix
       octokit (~> 4.7)
       terminal-table (~> 1)
@@ -131,9 +132,9 @@ GEM
       railties (>= 3.1)
     ember-source (2.18.2)
     erubi (1.8.0)
-    excon (0.62.0)
+    excon (0.64.0)
     execjs (2.7.0)
-    exifr (1.3.5)
+    exifr (1.3.6)
     fabrication (2.20.1)
     fakeweb (1.3.0)
     faraday (0.15.4)
@@ -174,13 +175,15 @@ GEM
     json (2.2.0)
     jwt (2.1.0)
     kgio (2.11.2)
-    kramdown (1.17.0)
+    kramdown (2.1.0)
+    kramdown-parser-gfm (1.0.1)
+      kramdown (~> 2.0)
     libv8 (7.3.492.27.1)
     listen (3.1.5)
       rb-fsevent (~> 0.9, >= 0.9.4)
       rb-inotify (~> 0.9, >= 0.9.7)
       ruby_dep (~> 1.2)
-    lograge (0.10.0)
+    lograge (0.11.0)
       actionpack (>= 4)
       activesupport (>= 4)
       railties (>= 4)
@@ -196,11 +199,11 @@ GEM
     mail (2.7.1)
       mini_mime (>= 0.1.1)
     maxminddb (0.1.22)
-    memory_profiler (0.9.12)
+    memory_profiler (0.9.13)
     message_bus (2.2.0)
       rack (>= 1.1.3)
     metaclass (0.0.4)
-    method_source (0.8.2)
+    method_source (0.9.2)
     mini_mime (1.0.1)
     mini_portile2 (2.4.0)
     mini_racer (0.2.5)
@@ -211,11 +214,11 @@ GEM
     mini_suffix (0.3.0)
       ffi (~> 1.9)
     minitest (5.11.3)
-    mocha (1.5.0)
+    mocha (1.8.0)
       metaclass (~> 0.0.1)
-    mock_redis (0.18.0)
+    mock_redis (0.19.0)
     moneta (1.1.1)
-    msgpack (1.2.6)
+    msgpack (1.2.10)
     multi_json (1.13.1)
     multi_xml (0.6.0)
     multipart-post (2.0.0)
@@ -233,9 +236,9 @@ GEM
       multi_json (~> 1.3)
       multi_xml (~> 0.5)
       rack (>= 1.2, < 3)
-    octokit (4.13.0)
+    octokit (4.14.0)
       sawyer (~> 0.8.0, >= 0.5.3)
-    oj (3.7.8)
+    oj (3.7.12)
     omniauth (1.9.0)
       hashie (>= 3.4.6, < 3.7.0)
       rack (>= 1.6.2, < 3)
@@ -282,13 +285,12 @@ GEM
       ast (~> 2.4.0)
     pg (1.1.4)
     progress (3.5.0)
-    pry (0.10.4)
+    pry (0.12.2)
       coderay (~> 1.1.0)
-      method_source (~> 0.8.1)
-      slop (~> 3.4)
-    pry-nav (0.2.4)
-      pry (>= 0.9.10, < 0.11.0)
-    pry-rails (0.3.6)
+      method_source (~> 0.9.0)
+    pry-nav (0.3.0)
+      pry (>= 0.9.10, < 0.13.0)
+    pry-rails (0.3.9)
       pry (>= 0.10.4)
     psych (3.1.0)
     public_suffix (3.0.3)
@@ -321,7 +323,7 @@ GEM
     rainbow (3.0.0)
     raindrops (0.19.0)
     rake (12.3.2)
-    rake-compiler (1.0.4)
+    rake-compiler (1.0.7)
       rake
     rb-fsevent (0.10.3)
     rb-inotify (0.10.0)
@@ -340,30 +342,30 @@ GEM
     rotp (3.3.1)
     rqrcode (0.10.1)
       chunky_png (~> 1.0)
-    rspec (3.7.0)
-      rspec-core (~> 3.7.0)
-      rspec-expectations (~> 3.7.0)
-      rspec-mocks (~> 3.7.0)
-    rspec-core (3.7.1)
-      rspec-support (~> 3.7.0)
-    rspec-expectations (3.7.0)
+    rspec (3.8.0)
+      rspec-core (~> 3.8.0)
+      rspec-expectations (~> 3.8.0)
+      rspec-mocks (~> 3.8.0)
+    rspec-core (3.8.0)
+      rspec-support (~> 3.8.0)
+    rspec-expectations (3.8.3)
       diff-lcs (>= 1.2.0, < 2.0)
-      rspec-support (~> 3.7.0)
+      rspec-support (~> 3.8.0)
     rspec-html-matchers (0.9.1)
       nokogiri (~> 1)
       rspec (>= 3.0.0.a, < 4)
-    rspec-mocks (3.7.0)
+    rspec-mocks (3.8.0)
       diff-lcs (>= 1.2.0, < 2.0)
-      rspec-support (~> 3.7.0)
-    rspec-rails (3.7.2)
+      rspec-support (~> 3.8.0)
+    rspec-rails (3.8.2)
       actionpack (>= 3.0)
       activesupport (>= 3.0)
       railties (>= 3.0)
-      rspec-core (~> 3.7.0)
-      rspec-expectations (~> 3.7.0)
-      rspec-mocks (~> 3.7.0)
-      rspec-support (~> 3.7.0)
-    rspec-support (3.7.1)
+      rspec-core (~> 3.8.0)
+      rspec-expectations (~> 3.8.0)
+      rspec-mocks (~> 3.8.0)
+      rspec-support (~> 3.8.0)
+    rspec-support (3.8.0)
     rtlit (0.0.5)
     rubocop (0.67.2)
       jaro_winkler (~> 1.5.1)
@@ -412,7 +414,6 @@ GEM
       json (>= 1.8, < 3)
       simplecov-html (~> 0.10.0)
     simplecov-html (0.10.2)
-    slop (3.6.0)
     sprockets (3.7.2)
       concurrent-ruby (~> 1.0)
       rack (> 1, < 3)
@@ -420,7 +421,7 @@ GEM
       actionpack (>= 4.0)
       activesupport (>= 4.0)
       sprockets (>= 3.0.0)
-    sshkey (1.9.0)
+    sshkey (2.0.0)
     stackprof (0.2.12)
     terminal-table (1.8.0)
       unicode-display_width (~> 1.1, >= 1.1.1)
@@ -440,7 +441,7 @@ GEM
       kgio (~> 2.6)
       raindrops (~> 0.7)
     uniform_notifier (1.12.1)
-    webmock (3.4.2)
+    webmock (3.5.1)
       addressable (>= 2.3.6)
       crack (>= 0.3.2)
       hashdiff

GitHub sha: 2d9c8581