DEV: Make it clear that plugin-api on the client side follows semver. (#15070)

DEV: Make it clear that plugin-api on the client side follows semver. (#15070)

diff --git a/app/assets/javascripts/discourse/app/lib/plugin-api.js b/app/assets/javascripts/discourse/app/lib/plugin-api.js
index e869e47..5d7d924 100644
--- a/app/assets/javascripts/discourse/app/lib/plugin-api.js
+++ b/app/assets/javascripts/discourse/app/lib/plugin-api.js
@@ -93,7 +93,8 @@ import {
 import { CUSTOM_USER_SEARCH_OPTIONS } from "select-kit/components/user-chooser";
 import { downloadCalendar } from "discourse/lib/download-calendar";
 
-// If you add any methods to the API ensure you bump up this number
+// If you add any methods to the API ensure you bump up the version number
+// based on Semantic Versioning 2.0.0.
 const PLUGIN_API_VERSION = "0.14.0";
 
 // This helper prevents us from applying the same `modifyClass` over and over in test mode.

GitHub sha: db5edc713b950ed8282526d76b79079892886616

This commit appears in #15070 which was approved by CvX and eviltrout. It was merged by tgxworld.