DEV: Prevent 'previous definition' warnings for PARAMETER_API_PATTERNS

DEV: Prevent ‘previous definition’ warnings for PARAMETER_API_PATTERNS

diff --git a/lib/auth/default_current_user_provider.rb b/lib/auth/default_current_user_provider.rb
index 0b0f647..36ba510 100644
--- a/lib/auth/default_current_user_provider.rb
+++ b/lib/auth/default_current_user_provider.rb
@@ -19,7 +19,7 @@ class Auth::DefaultCurrentUserProvider
   COOKIE_ATTEMPTS_PER_MIN ||= 10
   BAD_TOKEN ||= "_DISCOURSE_BAD_TOKEN"
 
-  PARAMETER_API_PATTERNS = [
+  PARAMETER_API_PATTERNS ||= [
     {
       method: :get,
       route: [

GitHub sha: ff331e84