DEV: Promote all `javascripts/discourse` devDependencies to dependencies (#14167)

DEV: Promote all javascripts/discourse devDependencies to dependencies (#14167)

diff --git a/app/assets/javascripts/discourse/package.json b/app/assets/javascripts/discourse/package.json
index 47f6f83..932954c 100644
--- a/app/assets/javascripts/discourse/package.json
+++ b/app/assets/javascripts/discourse/package.json
@@ -15,7 +15,7 @@
     "start": "ember serve",
     "test": "ember test"
   },
-  "devDependencies": {
+  "dependencies": {
     "@babel/core": "^7.14.3",
     "@ember/optional-features": "^1.1.0",
     "@ember/test-helpers": "^2.2.0",

GitHub sha: 189b4c49928cc90b929a23bcf6111f1054c2944f

This commit appears in #14167 which was approved by tshenry. It was merged by davidtaylorhq.