DEV: Promote all `javascripts/discourse` devDependencies to dependencies (PR #14167)

This is required so that we get all these dependencies installed when using yarn install with the --production flag

GitHub