DEV: pulls lodash-cli from git, package is not pushed to npm (#7882)

DEV: pulls lodash-cli from git, package is not pushed to npm (#7882)

diff --git a/package.json b/package.json
index 5f3b0e7..43aee39 100644
--- a/package.json
+++ b/package.json
@@ -38,13 +38,13 @@
     "chrome-launcher": "^0.10",
     "chrome-remote-interface": "^0.25",
     "eslint": "^4.19",
+    "lodash-cli": "https://github.com/lodash-archive/lodash-cli.git",
     "pretender": "^1.6",
     "prettier": "^1.18.2",
     "puppeteer": "1.16",
     "qunit": "2.8.0",
     "route-recognizer": "^0.3.3",
-    "sinon": "^7.2.5",
-    "lodash-cli": "^4"
+    "sinon": "^7.2.5"
   },
   "scripts": {
     "preinstall": "node -e \"if(process.env.npm_execpath.indexOf('yarn') === -1) throw new Error('NPM is not supported, please use Yarn instead. ')\""
diff --git a/yarn.lock b/yarn.lock
index a4d8585..8c05847 100644
--- a/yarn.lock
+++ b/yarn.lock
@@ -1534,21 +1534,20 @@ linkify-it@^2.0.0:
   dependencies:
     uc.micro "^1.0.1"
 
-lodash-cli@^4:
-  version "4.17.5"
-  resolved "https://registry.yarnpkg.com/lodash-cli/-/lodash-cli-4.17.5.tgz#1bab72c8c9980febf4fe7a1900b0971ce040dd0b"
-  integrity sha512-eeQi+oVS76ofP791g4wEGs4B4nyc4fiHboUCc0BzM8qCkLAzqbroewOt98A8ISoY1HH2di00pENNErXf0MWxiw==
+"lodash-cli@https://github.com/lodash-archive/lodash-cli.git":
+  version "4.17.14"
+  resolved "https://github.com/lodash-archive/lodash-cli.git#169d0651a93bb46edcd23b03f48026f3326dc0bc"
   dependencies:
     closure-compiler "0.2.12"
     glob "7.1.1"
-    lodash "4.17.5"
+    lodash "4.17.13"
     semver "5.3.0"
     uglify-js "2.7.5"
 
-lodash@4.17.5:
-  version "4.17.5"
-  resolved "https://registry.yarnpkg.com/lodash/-/lodash-4.17.5.tgz#99a92d65c0272debe8c96b6057bc8fbfa3bed511"
-  integrity sha512-svL3uiZf1RwhH+cWrfZn3A4+U58wbP0tGVTLQPbjplZxZ8ROD9VLuNgsRniTlLe7OlSqR79RUehXgpBW/s0IQw==
+lodash@4.17.13:
+  version "4.17.13"
+  resolved "https://registry.yarnpkg.com/lodash/-/lodash-4.17.13.tgz#0bdc3a6adc873d2f4e0c4bac285df91b64fc7b93"
+  integrity sha512-vm3/XWXfWtRua0FkUyEHBZy8kCPjErNBT9fJx8Zvs+U6zjqPbTUOpkaoum3O5uiA8sm+yNMHXfYkTUHFoMxFNA==
 
 lodash@^4.17.11, lodash@^4.17.4, lodash@^4.2.0, lodash@^4.3.0:
   version "4.17.14"

GitHub sha: c584a456

1 Like