DEV: Remove `addressable` dependency (#78)

DEV: Remove addressable dependency (#78)

It’s now included by default in core. Having it declared here makes updating it difficult. See: Build(deps): Bump addressable from 2.7.0 to 2.8.0 by dependabot · Pull Request #13625 · discourse/discourse · GitHub

diff --git a/plugin.rb b/plugin.rb
index 6eda43a..e37fb8a 100644
--- a/plugin.rb
+++ b/plugin.rb
@@ -6,8 +6,6 @@
 # authors: Sam Saffron
 # url: https://github.com/discourse/discourse-code-review
 
-# match version in discourse dev
-gem 'addressable', '2.7.0'
 gem 'sawyer', '0.8.2'
 gem 'octokit', '4.21.0'
 gem 'pqueue', '2.1.0'

GitHub sha: 773f10b6b2ce47b17b4d8291d28f2af017a2a494

This commit appears in #78 which was approved by tgxworld. It was merged by CvX.