DEV: Remove constant already initialized warning. (#29)

DEV: Remove constant already initialized warning. (#29)

require_dependency is only required in rare situations and should really be considered internal to Rails. A simple require would suffice here.

diff --git a/lib/reporter/web.rb b/lib/reporter/web.rb
index c18a276..190665c 100644
--- a/lib/reporter/web.rb
+++ b/lib/reporter/web.rb
@@ -1,6 +1,6 @@
 # frozen_string_literal: true
 #
-require_dependency 'middleware/request_tracker'
+require 'middleware/request_tracker'
 
 class DiscoursePrometheus::Reporter::Web
 

GitHub sha: 3b41ec8acd0d0195c44e43bae05be84af8448790

This commit appears in #29 which was approved by SamSaffron. It was merged by tgxworld.