DEV: Remove deprecated plugins variables importer (PR #12168)

Previously deprecated in DEV: Deprecate SCSS variable overrides in plugins (#11589) · discourse/discourse@7f1bafc · GitHub.

GitHub

What’s our deprecation policy? Shouldn’t it be: deprecate in a stable version, remove in the next stable? This code has been deprecated in 2.7.0.beta2 and will now be removed in 2.7.0.beta5 - isn’t this too quick of a turnaround?

It might be a bit quick, but I think it is safe, we know of no public plugins that use this. When deprecating this in December, I found one custom plugin using this endpoint and that plugin was updated in January.

Sounds fine to me! all-the-plugins ftw :smiley: