DEV: Remove ember-addons (PR #9559)

We weren’t using this very much and introduces a dependency between discourse-common and discourse which makes moving to yarn workspaces more difficult.

In the future we might user ember-addons properly but for now it’s easier to move the code into discourse-common.

Note the old folder is still there because at least one plugin was still requiring the old files. It will be removed in the future.

GitHub