DEV: remove musl support from Gemfile (#12689)

DEV: remove musl support from Gemfile (#12689)

We do not really support Discourse on Alpine linux / musl based distros.

We depend heavily on libc.

Besides this it looks like rubygems/bundler tends to handle this nuance incorrectly.

Remove it for now.

diff --git a/Gemfile.lock b/Gemfile.lock
index 52df7c8..6a25eb1 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -186,7 +186,6 @@ GEM
     libv8-node (15.14.0.0-x86_64-darwin-19)
     libv8-node (15.14.0.0-x86_64-darwin-20)
     libv8-node (15.14.0.0-x86_64-linux)
-    libv8-node (15.14.0.0-x86_64-linux-musl)
     listen (3.5.1)
       rb-fsevent (~> 0.10, >= 0.10.3)
       rb-inotify (~> 0.9, >= 0.9.10)

GitHub sha: d56da72f

This commit appears in #12689 which was approved by blake. It was merged by blake.