DEV: Remove `.ruby-version` file (PR #14818)

I think this was added accidentally in DEV: Plugin instance method for push_notification_filters by markvanlan · Pull Request #14787 · discourse/discourse · GitHub.

GitHub

We should also add this file in .gitignore?