DEV: remove support from EOL Ruby

DEV: remove support from EOL Ruby

2.5 no longer gets security updates, stop supporting it.

diff --git a/prometheus_exporter.gemspec b/prometheus_exporter.gemspec
index 1537e6f..be9f0f7 100644
--- a/prometheus_exporter.gemspec
+++ b/prometheus_exporter.gemspec
@@ -42,5 +42,5 @@ Gem::Specification.new do |spec|
   if !RUBY_ENGINE == 'jruby'
     spec.add_development_dependency "raindrops", "~> 0.19"
   end
-  spec.required_ruby_version = '>= 2.5.0'
+  spec.required_ruby_version = '>= 2.6.0'
 end

GitHub sha: b71851dccc1baa3b9aabf00104459f38852a5f3c