DEV: Remove tool-versions used by asdf package manager. (PR #12959)

Reverts ce17eb9ee622bb84e4be8c3e5bc9ad0e94ff76c9

We really shouldn’t be adding a development configuration file for asdf into the repo. Not everyone uses asdf for package management and for those that do, this prevents them from using other versions of Ruby and Nodejs in their development enviornment.

GitHub

@eviltrout @xfalcox I’m with @CvX on this that this shouldn’t be checked into the repo. This is a development configuration file for asdf that not everyone uses. On top of that, it prevents developers that are using asdf from using other versions of Ruby and Nodejs locally.

I’m good to remove it.