DEV: Remove unnecessary requires (#15067)

DEV: Remove unnecessary requires (#15067)

auth/* one was causing warnings (the file was loaded twice)

and sha1 isn’t used anymore here

diff --git a/lib/discourse.rb b/lib/discourse.rb
index dd599d1..66ea0b7 100644
--- a/lib/discourse.rb
+++ b/lib/discourse.rb
@@ -3,11 +3,8 @@
 
 require 'cache'
 require 'open3'
-require_dependency 'route_format'
 require_dependency 'plugin/instance'
-require_dependency 'auth/default_current_user_provider'
 require_dependency 'version'
-require 'digest/sha1'
 
 module Discourse
   DB_POST_MIGRATE_PATH ||= "db/post_migrate"

GitHub sha: d40e56272f1d3c6dc72f423c2fd5727c24dfdd00

This commit appears in #15067 which was approved by eviltrout. It was merged by CvX.