DEV: Remove unnecessary requires (PR #15067)

auth/* one was causing warnings (the file was loaded twice)

and sha1 isn’t used anymore here

GitHub