DEV: Run Ember CLI tests in Firefox evergreen too (#14283)

DEV: Run Ember CLI tests in Firefox evergreen too (#14283)

Increases timeout and removes parallelism to make it stable.

diff --git a/.github/workflows/ember.yml b/.github/workflows/ember.yml
index a3d1d7d..b691a6c 100644
--- a/.github/workflows/ember.yml
+++ b/.github/workflows/ember.yml
@@ -14,7 +14,7 @@ jobs:
     if: true
     runs-on: ubuntu-latest
     container: discourse/discourse_test:release
-    timeout-minutes: 40
+    timeout-minutes: 60
 
     steps:
       - uses: actions/checkout@master
@@ -50,4 +50,4 @@ jobs:
       - name: Core QUnit
         working-directory: ./app/assets/javascripts/discourse
         run: sudo -E -u discourse -H yarn ember test
-        timeout-minutes: 30
+        timeout-minutes: 60
diff --git a/app/assets/javascripts/discourse/testem.js b/app/assets/javascripts/discourse/testem.js
index 1bc59b3..00a1232 100644
--- a/app/assets/javascripts/discourse/testem.js
+++ b/app/assets/javascripts/discourse/testem.js
@@ -1,9 +1,9 @@
 module.exports = {
   test_page: "tests/index.html?hidepassed",
   disable_watching: true,
-  launch_in_ci: ["Chrome", "Firefox"],
+  launch_in_ci: ["Chrome", "Firefox", "Headless Firefox"], // Firefox is old ESR version, Headless Firefox is up-to-date evergreen version
   launch_in_dev: ["Chrome"],
-  parallel: -1, // run Firefox and Chrome in parallel
+  parallel: 1, // disable parallel tests for stability
   browser_args: {
     Chrome: [
       // --no-sandbox is needed when running Chrome inside a container
@@ -16,5 +16,9 @@ module.exports = {
       "--window-size=1440,900",
     ].filter(Boolean),
     Firefox: ["-headless", "--width=1440", "--height=900"],
+    "Headless Firefox": ["--width=1440", "--height=900"],
+  },
+  browser_paths: {
+    "Headless Firefox": "/opt/firefox-evergreen/firefox",
   },
 };

GitHub sha: 789613fe51733f108f97a926e22f409421e18fbc

This commit appears in #14283 which was approved by eviltrout. It was merged by Falco.