DEV: specify eslint-config-discourse version instead of using latest (PR #10721)

This make it easy for users to be on latest when they pull an update.

GitHub