DEV: Support Node 15 with Ember CLI (PR #12679)

By upgrading a lot of packages (but not Ember itself) we can run Ember CLI on the latest version of Node.

This allows us to run Ember CLI on Apple Silicon.

GitHub

Should other sub-project yarn.lock files be removed as well?

I’m not sure, but I confirmed during debugging that this one is not necessary. I think that would be a really low priority change.

:tada:

The test can now be moved into integration/components :smiley: