DEV: Switch from Transifex to Crowdin

DEV: Switch from Transifex to Crowdin

diff --git a/.tx/config b/.tx/config
deleted file mode 100644
index 572d0c8..0000000
--- a/.tx/config
+++ /dev/null
@@ -1,15 +0,0 @@
-[main]
-host = https://www.transifex.com
-lang_map = el_GR: el, es_ES: es, fr_FR: fr, hu_HU: hu, ko_KR: ko, pt_PT: pt, sk_SK: sk, vi_VN: vi
-
-[discourse-org.pluginstaff-notesclientenyml]
-file_filter = config/locales/client.<lang>.yml
-source_file = config/locales/client.en.yml
-source_lang = en
-type = YML
-
-[discourse-org.pluginstaff-notesserverenyml]
-file_filter = config/locales/server.<lang>.yml
-source_file = config/locales/server.en.yml
-source_lang = en
-type = YML
diff --git a/Gemfile b/Gemfile
index 85c1173..7da32ec 100644
--- a/Gemfile
+++ b/Gemfile
@@ -3,6 +3,5 @@
 source 'https://rubygems.org'
 
 group :development do
-  gem 'translations-manager', git: 'https://github.com/discourse/translations-manager.git'
   gem 'rubocop-discourse'
 end
diff --git a/Gemfile.lock b/Gemfile.lock
index d42de0d..bf6ad09 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -1,32 +1,29 @@
-GIT
-  remote: https://github.com/discourse/translations-manager.git
-  revision: d6da5ff928b9ea39a15c9b6f16b856f46bc9069b
-  specs:
-    translations-manager (0.6)
-
 GEM
   remote: https://rubygems.org/
   specs:
-    ast (2.4.0)
-    jaro_winkler (1.5.4)
-    parallel (1.19.1)
-    parser (2.7.1.2)
-      ast (~> 2.4.0)
+    ast (2.4.1)
+    parallel (1.19.2)
+    parser (2.7.1.4)
+      ast (~> 2.4.1)
     rainbow (3.0.0)
+    regexp_parser (1.7.1)
     rexml (3.2.4)
-    rubocop (0.82.0)
-      jaro_winkler (~> 1.5.1)
+    rubocop (0.88.0)
       parallel (~> 1.10)
-      parser (>= 2.7.0.1)
+      parser (>= 2.7.1.1)
       rainbow (>= 2.2.2, < 4.0)
+      regexp_parser (>= 1.7)
       rexml
+      rubocop-ast (>= 0.1.0, < 1.0)
       ruby-progressbar (~> 1.7)
       unicode-display_width (>= 1.4.0, < 2.0)
-    rubocop-discourse (2.1.2)
+    rubocop-ast (0.1.0)
+      parser (>= 2.7.0.1)
+    rubocop-discourse (2.2.0)
       rubocop (>= 0.69.0)
       rubocop-rspec (>= 1.39.0)
-    rubocop-rspec (1.39.0)
-      rubocop (>= 0.68.1)
+    rubocop-rspec (1.42.0)
+      rubocop (>= 0.87.0)
     ruby-progressbar (1.10.1)
     unicode-display_width (1.7.0)
 
@@ -35,7 +32,6 @@ PLATFORMS
 
 DEPENDENCIES
   rubocop-discourse
-  translations-manager!
 
 BUNDLED WITH
    2.1.4
diff --git a/bin/pull_translations.rb b/bin/pull_translations.rb
deleted file mode 100755
index 789ccaa..0000000
--- a/bin/pull_translations.rb
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/usr/bin/env ruby
-# frozen_string_literal: true
-
-# Usage:
-#   bundle install
-#   bundle exec bin/pull_translations.rb
-#
-# To choose which languages to update, list them as arguments:
-#   bundle exec bin/pull_translations.rb he uk
-
-require 'translations_manager'
-
-YML_DIRS = ['config/locales'].map { |d| File.expand_path(d) }
-YML_FILE_PREFIXES = ['server', 'client']
-
-TranslationsManager::TransifexUpdater.new(YML_DIRS, YML_FILE_PREFIXES, *ARGV).perform
diff --git a/translator.yml b/translator.yml
new file mode 100644
index 0000000..5caa8f7
--- /dev/null
+++ b/translator.yml
@@ -0,0 +1,7 @@
+# Configuration file for discourse-translator-bot
+
+files:
+- source_path: config/locales/client.en.yml
+  destination_path: client.yml
+- source_path: config/locales/server.en.yml
+  destination_path: server.yml

GitHub sha: be8d2130