DEV: Update `caniuse-lite` (PR #14926)

The repeated notices in the console were tiring…

Browserslist: caniuse-lite is outdated. Please run:
npx browserslist@latest --update-db

Why you should do it regularly:
https://github.com/browserslist/browserslist#browsers-data-updating

GitHub

Tons of weird plugin errors here, not sure if related.

Those are the flaky discourse-encrypt tests.

Cool, approved then :slight_smile: