DEV: update dependencies

DEV: update dependencies

This updates some more low risk gems, maxmind, hiredis (c wrapper for redis), puma, rbtrace and stackprof.

diff --git a/Gemfile.lock b/Gemfile.lock
index d1a6f4c..24e9688 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -153,7 +153,7 @@ GEM
     hashdiff (0.3.7)
     hashie (3.6.0)
     highline (1.7.10)
-    hiredis (0.6.1)
+    hiredis (0.6.3)
     hkdf (0.3.0)
     htmlentities (4.3.4)
     http_accept_language (2.0.5)
@@ -190,7 +190,7 @@ GEM
     lru_redux (1.1.0)
     mail (2.7.1)
       mini_mime (>= 0.1.1)
-    maxminddb (0.1.21)
+    maxminddb (0.1.22)
     memory_profiler (0.9.12)
     message_bus (2.2.0)
       rack (>= 1.1.3)
@@ -269,12 +269,13 @@ GEM
     openid-redis-store (0.0.2)
       redis
       ruby-openid
+    optimist (3.0.0)
     parallel (1.13.0)
     parser (2.6.0.0)
       ast (~> 2.4.0)
     pg (1.1.4)
     powerpack (0.1.2)
-    progress (3.4.0)
+    progress (3.5.0)
     pry (0.10.4)
       coderay (~> 1.1.0)
       method_source (~> 0.8.1)
@@ -284,7 +285,7 @@ GEM
     pry-rails (0.3.6)
       pry (>= 0.10.4)
     public_suffix (3.0.3)
-    puma (3.11.4)
+    puma (3.12.0)
     r2 (0.2.7)
     rack (2.0.6)
     rack-mini-profiler (1.0.1)
@@ -318,10 +319,10 @@ GEM
     rb-fsevent (0.10.3)
     rb-inotify (0.9.10)
       ffi (>= 0.5.0, < 2)
-    rbtrace (0.4.10)
+    rbtrace (0.4.11)
       ffi (>= 1.0.6)
       msgpack (>= 0.4.3)
-      trollop (>= 1.16.2)
+      optimist (>= 3.0.0)
     rchardet (1.8.0)
     redis (4.0.1)
     redis-namespace (1.6.0)
@@ -412,13 +413,12 @@ GEM
       activesupport (>= 4.0)
       sprockets (>= 3.0.0)
     sshkey (1.9.0)
-    stackprof (0.2.11)
+    stackprof (0.2.12)
     terminal-table (1.8.0)
       unicode-display_width (~> 1.1, >= 1.1.1)
     thor (0.20.3)
     thread_safe (0.3.6)
     tilt (2.0.8)
-    trollop (2.1.2)
     tzinfo (1.2.5)
       thread_safe (~> 0.1)
     uglifier (4.1.20)

GitHub sha: 27c8688f