DEV: update mini_racer for ARM support (PR #12682)

New version of mini_racer support M1 and ARM builds of Ruby

This should make developing on Discourse easier

GitHub

Awesome, going to test shortly.