DEV: Update mocha (#9490)

DEV: Update mocha (#9490)

The spec that was blocking the update was fixed in c08753dc3431ce2f85916b5a7e68db52891917d8.

diff --git a/Gemfile b/Gemfile
index d0844e4..c440694 100644
--- a/Gemfile
+++ b/Gemfile
@@ -160,10 +160,7 @@ group :test, :development do
   gem 'listen', require: false
   gem 'certified', require: false
   gem 'fabrication', require: false
-
-  # TODO: upgrading to 1.10.1 cause it breaks our test suite.
-  # We want our test suite fixed though to support this upgrade.
-  gem 'mocha', '1.8.0', require: false
+  gem 'mocha', require: false
 
   gem 'rb-fsevent', require: RUBY_PLATFORM =~ /darwin/i ? 'rb-fsevent' : false
 
diff --git a/Gemfile.lock b/Gemfile.lock
index b79091b..3a60704 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -184,7 +184,6 @@ GEM
     memory_profiler (0.9.14)
     message_bus (2.2.4)
       rack (>= 1.1.3)
-    metaclass (0.0.4)
     method_source (0.9.2)
     mini_mime (1.0.2)
     mini_portile2 (2.4.0)
@@ -196,8 +195,7 @@ GEM
     mini_suffix (0.3.0)
       ffi (~> 1.9)
     minitest (5.14.0)
-    mocha (1.8.0)
-      metaclass (~> 0.0.1)
+    mocha (1.11.2)
     mock_redis (0.22.0)
     msgpack (1.3.3)
     multi_json (1.14.1)
@@ -488,7 +486,7 @@ DEPENDENCIES
   mini_sql
   mini_suffix
   minitest
-  mocha (= 1.8.0)
+  mocha
   mock_redis
   multi_json
   mustache

GitHub sha: 07e0490f

This commit appears in #9490 which was approved by eviltrout. It was merged by CvX.