DEV: Update pretender and fake-xml-http-request (PR #13937)

We are still on a version of pretender since 2017

Since then many changes have been made, including adding support for xhr.upload. Upgrading will let us write proper acceptance tests for uppy, which uses XmlHTTPRequest internally including xhr.upload.

Note: There have been no breaking changes in the releases that would affect us, mainly dropping support for old node versions.

GitHub

Please do the same in app/assets/javascripts/discourse/package.json and run yarn to update the yarn-lock. (to keep the ember-cli version in sync) :slightly_smiling_face:

@CvX ah thanks for reminding me, done now!