DEV: update required ruby version to 2.4

DEV: update required ruby version to 2.4

diff --git a/.travis.yml b/.travis.yml
index 5596c69..3689fc1 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,9 @@
 language: ruby
 sudo: false
 rvm:
-  - 2.3
   - 2.4
   - 2.5
+  - 2.6
 notifications:
   email:
     on_success: change
@@ -14,4 +14,4 @@ script:
 cache:
   bundler: true
 before_install:
-  - gem install bundler
\ No newline at end of file
+  - gem install bundler
diff --git a/README.md b/README.md
index e892881..cdf7fd7 100644
--- a/README.md
+++ b/README.md
@@ -75,7 +75,7 @@ Ruby Support
 
 The onebox library is supported on all "officially" supported versions of Ruby.
 
-This means you must be on Ruby 2.3 or above for it to work.
+This means you must be on Ruby 2.4 or above for it to work.
 
 Development Preview Interface
 -----------------------------
@@ -211,7 +211,7 @@ Issues / Discussion
 -------------------
 
 Discussion of the Onebox gem, its development and features should be done on
-[Discourse Meta](https://meta.discourse.org). 
+[Discourse Meta](https://meta.discourse.org).
 
 Contributing
 ------------
diff --git a/onebox.gemspec b/onebox.gemspec
index 178622e..a553472 100644
--- a/onebox.gemspec
+++ b/onebox.gemspec
@@ -41,5 +41,5 @@ Gem::Specification.new do |spec|
   spec.add_development_dependency 'haml', '~> 4.0'
   spec.add_development_dependency 'listen', '~> 2.10.0'
 
-  spec.required_ruby_version = '>=2.3.0'
+  spec.required_ruby_version = '>=2.4.0'
 end

GitHub sha: 4789da73

Ruby 2.3 is in EOL phase.