DEV: update rspec dependencies

DEV: update rspec dependencies

rspec-rails 4.0 was released so we no longer need to depend on a beta version. Also updates minor on a bunch of rspec gems.

Thanks to @ryanwi for raising this.

diff --git a/Gemfile b/Gemfile
index a0f43d3..742bf82 100644
--- a/Gemfile
+++ b/Gemfile
@@ -167,8 +167,7 @@ group :test, :development do
   # we would like to upgrade it if possible
   gem 'rb-inotify', '~> 0.9', require: RUBY_PLATFORM =~ /linux/i ? 'rb-inotify' : false
 
-  # TODO once 4.0.0 is released upgrade to it, at time of writing 3.9.0 is latest
-  gem 'rspec-rails', '4.0.0.beta2', require: false
+  gem 'rspec-rails'
 
   gem 'shoulda-matchers', require: false
   gem 'rspec-html-matchers'
diff --git a/Gemfile.lock b/Gemfile.lock
index 0ffefbc..d16ced6 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -317,8 +317,8 @@ GEM
       rspec-core (~> 3.9.0)
       rspec-expectations (~> 3.9.0)
       rspec-mocks (~> 3.9.0)
-    rspec-core (3.9.1)
-      rspec-support (~> 3.9.1)
+    rspec-core (3.9.2)
+      rspec-support (~> 3.9.3)
     rspec-expectations (3.9.1)
       diff-lcs (>= 1.2.0, < 2.0)
       rspec-support (~> 3.9.0)
@@ -328,15 +328,15 @@ GEM
     rspec-mocks (3.9.1)
       diff-lcs (>= 1.2.0, < 2.0)
       rspec-support (~> 3.9.0)
-    rspec-rails (4.0.0.beta2)
+    rspec-rails (4.0.0)
       actionpack (>= 4.2)
       activesupport (>= 4.2)
       railties (>= 4.2)
-      rspec-core (~> 3.8)
-      rspec-expectations (~> 3.8)
-      rspec-mocks (~> 3.8)
-      rspec-support (~> 3.8)
-    rspec-support (3.9.2)
+      rspec-core (~> 3.9)
+      rspec-expectations (~> 3.9)
+      rspec-mocks (~> 3.9)
+      rspec-support (~> 3.9)
+    rspec-support (3.9.3)
     rswag-specs (2.3.1)
       activesupport (>= 3.1, < 7.0)
       json-schema (~> 2.2)
@@ -525,7 +525,7 @@ DEPENDENCIES
   rqrcode
   rspec
   rspec-html-matchers
-  rspec-rails (= 4.0.0.beta2)
+  rspec-rails
   rswag-specs
   rtlit
   rubocop

GitHub sha: 57fcea77