DEV: Update supported node versions (PR #15073)

13 and 15 are no longer supported by node, and issues with discourse dependencies prevent us from using 17. (for now)

GitHub