DEV: Update the rubocop-discourse usage

DEV: Update the rubocop-discourse usage

diff --git a/.rubocop.yml b/.rubocop.yml
index 7882c19..d46296c 100644
--- a/.rubocop.yml
+++ b/.rubocop.yml
@@ -1,6 +1,2 @@
-inherit_from: https://raw.githubusercontent.com/discourse/discourse/master/.rubocop.yml
-AllCops:
-  TargetRubyVersion: 2.4
-  DisabledByDefault: true
-  Exclude:
-    - 'spec/**/**/*.rb'
+inherit_gem:
+  rubocop-discourse: default.yml
diff --git a/discourse_api.gemspec b/discourse_api.gemspec
index 4472c5a..2f26316 100644
--- a/discourse_api.gemspec
+++ b/discourse_api.gemspec
@@ -30,9 +30,7 @@ Gem::Specification.new do |spec|
   spec.add_development_dependency 'rspec', '~> 3.4'
   spec.add_development_dependency 'simplecov', '~> 0.11'
   spec.add_development_dependency 'webmock', '~> 2.0'
-  spec.add_development_dependency 'rubocop'
   spec.add_development_dependency 'rubocop-discourse'
-  spec.add_development_dependency 'rubocop-rspec'
 
   spec.required_ruby_version = '>= 2.2.3'
 end

GitHub sha: 04099d68

1 Like

Oh cool, thank you!!!

1 Like

I meant to ping you in DEV: Update rubocop-discourse (#9270) that I eventually followed up on that issue. :sweat_smile:

1 Like